GoToMeeting discontinuing older OS support

Direct Link to Article

GoToMeeting will be discontinuing product support on April 1 for older operating systems, including Windows XP, Windows Vista and Mac OS X 10.8 (Mountain Lion). If you currently use one of these operating systems, you'll need to upgrade to a supported OS to start or join a session after this date. This includes GoToMeeting, GoToWebinar and GoToTraining products. More information can be found at the following site:

http://support.citrixonline.com/Meeting/knowledge_articles/000262214?mkt_tok=3RkMMJWWfF9wsRogvqrAcu%2FhmjTEU5z17%2BkpW6GxgYkz2EFye%2BLIHETpodcMS8drMb%2FYDBceEJhqyQJxPr3BLNMN29J7RhjgCA%3D%3D.

If you have any questions about operating system upgrades, contact IT Help at 7-1111 or it-help@mtu.edu.